top of page

グループ

公開·44名のメンバー
Benjamin Walker
Benjamin Walker

Ufo Afterlight Windows 7 64 Bit Patch


Any help on getting either game to work would be great. I have tried several different things to fix it myself that didn't work. I downloaded the 1.7 patch for Afterlight, but when installing the patch I get an error message saying it cannot locate the file gamedata.vfs even though I can see the file in the afterlight folder.




Ufo Afterlight Windows 7 64 Bit Patch



Ok, this is really odd now. I posted the above about the 2 games not starting after messing with it the last 2 days. I also went into the control panel under programs and features and tried to "Run programs made for previous versions of Windows" on both afterlight and aftershock and neither would start up. Aftershock giving me some other error but still the assert_fatal box at start up, and afterlight was denied.


Now afterlight is starting up even though there isn't an openAL32.dll file in the folder and even though I couldn't get the 1.7 patch to install. The Afterlight game doesn't fit the screen properly and leaves an inch of my background up on the right side, but the game starts up and looks like it will play. All that is left is to get Aftershock working


By the way, that openAL32.dll is a system library and you'll find it in windows/system32, if nothing else helps, you may also download its latest version and replace it, i recommend to leave a backup of this one though.


I am afraid I wont be of much more help because I am playing UFO games on older hardware and never had issues with any of them, excluding frighteningly buggy 1.0 Aftershock. Mentioning that, even after patching Aftershock out it's a picky game, you'll best run it on a classic pc with single non integrated GPU. I'm not surprised it didn't work on SLI GTXs. The Afterlight, however, is much more friendly and should be running just fine. Here I can only tell that it is not OS related, I play both Afterlight and Aftershock on WinXP 32bit and Win7 64bit and no problem so far.


The patch unfortunately made no difference. It still crashes in the same place, the same way, on all executables. In any event, I don't think that's the issue - I'm not getting any errors about OpenGL 1.3 not being supported.


For the benefit of anyone Googling this problem and finding their way here, this was the only thing necessary to make the game work. Well, I patched it to 1.1 too, but I always patch to the latest version anyway. I did not need to use unofficial patches, or compatibility mode, or Run As Admin, or single core affinity, and the game automatically selects the 64-bit mode.


グループについて

グループへようこそ!他のメンバーと交流したり、最新情報をチェックしたり、動画をシェアすることもできます。

メンバー

bottom of page